CVE-2022-28739

CVE Details

Release Date:2022-05-09

Description


There is a buffer over-read in Ruby before 2.6.10, 2.7.x before 2.7.6, 3.x before 3.0.4, and 3.1.x before 3.1.2. It occurs in String-to-Float conversion, including Kernel#Float and String#to_f.

See more information about CVE-2022-28739 from MITRE CVE dictionary and NIST NVD


CVSS v3.0 metrics


NOTE: The following CVSS v3.0 metrics and score provided are preliminary and subject to review.

Base Score: 7.5 Base Metrics: AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Access Vector: Network Attack Complexity: Low
Privileges Required: None User Interaction: None
Scope: Unchanged Confidentiality Impact: High
Integrity Impact: None Availability Impact: None

Errata information


PlatformErrataRelease Date
Oracle Linux version 8 (ruby)ELSA-2022-53382022-07-01
Oracle Linux version 8 (rubygem-abrt)ELSA-2022-53382022-07-01
Oracle Linux version 8 (rubygem-bson)ELSA-2022-53382022-07-01
Oracle Linux version 8 (rubygem-mongo)ELSA-2022-53382022-07-01
Oracle Linux version 8 (rubygem-mysql2)ELSA-2022-53382022-07-01
Oracle Linux version 8 (rubygem-pg)ELSA-2022-53382022-07-01



This page is generated automatically and has not been checked for errors or omissions. For clarification or corrections please contact the Oracle Linux ULN team

software.hardware.complete