CVE-2022-32189

CVE Details

Release Date:2022-08-10

Description


A too-short encoded message can cause a panic in Float.GobDecode and Rat GobDecode in math/big in Go before 1.17.13 and 1.18.5, potentially allowing a denial of service.

See more information about CVE-2022-32189 from MITRE CVE dictionary and NIST NVD


CVSS v3.0 metrics


NOTE: The following CVSS v3.0 metrics and score provided are preliminary and subject to review.

Base Score: 7.5 Base Metrics: AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Access Vector: Network Attack Complexity: Low
Privileges Required: None User Interaction: None
Scope: Unchanged Confidentiality Impact: None
Integrity Impact: None Availability Impact: High

Errata information


PlatformErrataRelease Date
Oracle Linux version 7 (golang)ELSA-2022-206932022-09-06
Oracle Linux version 7 (golang)ELSA-2022-206942022-09-07
Oracle Linux version 8 (cockpit-composer)ELSA-2022-75482022-11-15
Oracle Linux version 8 (delve)ELSA-2022-236812022-11-07
Oracle Linux version 8 (delve)ELSA-2022-242672022-11-23
Oracle Linux version 8 (git-lfs)ELSA-2022-71292022-10-26
Oracle Linux version 8 (go-toolset)ELSA-2022-236812022-11-07
Oracle Linux version 8 (go-toolset)ELSA-2022-242672022-11-23
Oracle Linux version 8 (golang)ELSA-2022-236812022-11-07
Oracle Linux version 8 (golang)ELSA-2022-242672022-11-23
Oracle Linux version 8 (osbuild)ELSA-2022-75482022-11-15
Oracle Linux version 8 (osbuild-composer)ELSA-2022-75482022-11-15
Oracle Linux version 8 (weldr-client)ELSA-2022-75482022-11-15
Oracle Linux version 9 (cockpit-composer)ELSA-2022-79502022-11-22
Oracle Linux version 9 (osbuild)ELSA-2022-79502022-11-22
Oracle Linux version 9 (osbuild-composer)ELSA-2022-79502022-11-22
Oracle Linux version 9 (weldr-client)ELSA-2022-79502022-11-22



This page is generated automatically and has not been checked for errors or omissions. For clarification or corrections please contact the Oracle Linux ULN team

software.hardware.complete