ELBA-2020-5496

ELBA-2020-5496 - container-tools:ol8 bug fix update

Type:BUG
Severity:NA
Release Date:2021-01-06

Description


buildah
[1.15.1-2.0.1]
- Handling redirect from the docker registry [Orabug: 29874238] (Nikita Gerasimov)

[1.15.1-2]
- propagate proper CFLAGS to CGO_CFLAGS to assure code hardening and optimization
- Related: #1821193

[1.15.1-1]
- update to https://github.com/containers/buildah/releases/tag/v1.15.1
- Related: #1821193

[1.15.0-2]
- fix 'CVE-2020-14040 buildah: golang.org/x/text: possibility to trigger an infinite loop in encoding/unicode could lead to crash [rhel-8]'
- Resolves: #1854717

[1.15.0-1]
- update to https://github.com/containers/buildah/releases/tag/v1.15.0
- Related: #1821193

[1.14.9-2]
- exclude i686 arch
- Related: #1821193

[1.14.9-1]
- update to https://github.com/containers/buildah/releases/tag/v1.14.9
- Related: #1821193

[1.14.8-1]
- synchronize containter-tools 8.3.0 with 8.2.1
- Related: #1821193

cockpit-podman
[18.1-2]
- revert back to 18.1 as this version is aimed at 8.3.0
- Related: #1821193

[19-1]
- update to https://github.com/cockpit-project/cockpit-podman/releases/tag/19
- Related: #1821193

[18.1-1]
- Fix AppStream metainfo (rhbz#1854673)

[18-1]
- update to https://github.com/cockpit-project/cockpit-podman/releases/tag/v18
- Related: #1821193

[17-1]
- update to https://github.com/cockpit-project/cockpit-podman/releases/tag/17
- Related: #1821193

[16-1]
- synchronize containter-tools 8.3.0 with 8.2.1
- Related: #1821193

[15-1]
- Drop obsolete functionality for Fedora Atomic
- Localize dates and times
- Make tests non-destructive, to support gating
- Fix crash on filtering anonymous images
- Translation updates
- Show historical logs

[12-1]
- Configure CPU share for system containers
- Translation updates

conmon
[2:2.0.20-2]
- use proper CFLAGS
- Related: #1821193

[2:2.0.20-1]
- update to https://github.com/containers/conmon/releases/tag/v2.0.20
- Related: #1821193

[2:2.0.19-1]
- update to https://github.com/containers/conmon/releases/tag/v2.0.19
- Related: #1821193

[2:2.0.18-1]
- update to https://github.com/containers/conmon/releases/tag/v2.0.18
- Related: #1821193

[2:2.0.17-1]
- update to https://github.com/containers/conmon/releases/tag/v2.0.17
- Related: #1821193

[2:2.0.16-1]
- update to https://github.com/containers/conmon/releases/tag/v2.0.16
- Related: #1821193

[2:2.0.15-2]
- synchronize containter-tools 8.3.0 with 8.2.1
- Related: #1821193

containernetworking-plugins
[0.8.6-2]
- propagate proper CFLAGS to CGO_CFLAGS to assure code hardening and optimization
- Related: #1821193

[0.8.6-1]
- update to https://github.com/containernetworking/plugins/releases/tag/v0.8.6
- Related: #1821193

[0.8.5-1]
- synchronize containter-tools 8.3.0 with 8.2.1
- Related: #1821193

[0.8.3-5]
- compile with no_openssl
- Related: RHELPLAN-25139

container-selinux
[2:2.144.0-1]
- update to https://github.com/containers/container-selinux/releases/tag/v2.144.0
- Related: #1821193

[2:2.143.0-1]
- update to https://github.com/containers/container-selinux/releases/tag/v2.143.0
- Related: #1821193

[2:2.142.0-1]
- update to https://github.com/containers/container-selinux/releases/tag/v2.142.0
- Related: #1821193

[2:2.139.0-1]
- update to https://github.com/containers/container-selinux/releases/tag/v2.139.0
- Related: #1821193

[2:2.138.0-1]
- update to https://github.com/containers/container-selinux/releases/tag/v2.138.0
- Related: #1821193

[2:2.137.0-1]
- update to https://github.com/containers/container-selinux/releases/tag/v2.137.0
- Related: #1821193

[2:2.135.0-1]
- update to https://github.com/containers/container-selinux/releases/tag/v2.135.0
- Related: #1821193

[2:2.134.0-1]
- update to https://github.com/containers/container-selinux/releases/tag/v2.134.0
- Related: #1821193

[2:2.132.0-1]
- synchronize containter-tools 8.3.0 with 8.2.1
- Related: #1821193

criu
[3.14-2]
- fix 'Need to fix bugs found by coverity.'
- Related: #1821193

[3.14-1]
- synchronize containter-tools 8.3.0 with 8.2.1
- Related: #1821193

crun
[0.14.1-2]
- use proper CFLAGS
- Related: #1821193

[0.14.1-1]
- update to https://github.com/containers/crun/releases/tag/v0.14.1
- Related: #1821193

[0.14-1]
- update to https://github.com/containers/crun/releases/tag/v0.14
- Related: #1821193

[0.13-1]
- initial import

fuse-overlayfs
[1.1.2-3]
- fix 'error bind mounting /dev from host into mount namespace'
(the openat2 syscall is not yet supported by the RHEL8 kernel)
- Resolves: #1867447

[1.1.2-2]
- use proper CFLAGS
- Related: #1821193

[1.1.2-1]
- update to https://github.com/containers/fuse-overlayfs/releases/tag/v1.1.2
- Related: #1821193

[1.1.1-1]
- update to https://github.com/containers/fuse-overlayfs/releases/tag/v1.1.1
- Related: #1821193

[1.1.0-1]
- update to https://github.com/containers/fuse-overlayfs/releases/tag/v1.1.0
- Related: #1821193

[1.0.0-1]
- synchronize containter-tools 8.3.0 with 8.2.1
- Related: #1821193

libslirp
[4.3.1-1]
- update to https://gitlab.freedesktop.org/slirp/libslirp/-/releases/v4.3.1
- Related: #1821193

[4.3.0-5]
- replace patch for CVE-2020-10756 with dedicated upstream one
- Related: #1821193

[4.3.0-4]
- fix 'CVE-2020-10756 QEMU: slirp: networking out-of-bounds read information disclosure vulnerability'
- Related: #1821193

oci-seccomp-bpf-hook
[1.1.2-3]
- propagate proper CFLAGS to CGO_CFLAGS to assure code hardening and optimization
- Related: #1821193

[1.1.2-2]
- Resolves: #1857606

[1.1.2-1]
- update to https://github.com/containers/oci-seccomp-bpf-hook/releases/tag/v1.1.2
- Related: #1821193

[1.1.1-1]
- update to https://github.com/containers/oci-seccomp-bpf-hook/releases/tag/v1.1.1
- Related: #1821193

[1.1.0-2]
- exclude i686 arch as bcc, the build dependency is not built
for it
- Related: #1821193

[1.1.0-1]
- initial build for container-tools-rhel8
- Related: #1821193

python-podman-api
[1.2.0-0.2.gitd0a45fe]
- revert update to 1.6.0 due to new python3-pbr dependency which
is not in RHEL
- Related: RHELPLAN-25139

[1.2.0-0.1.gitd0a45fe]
- Initial package

runc
[1.0.0-68.rc92]
- update to https://github.com/opencontainers/runc/releases/tag/v1.0.0-rc92
- propagate proper CFLAGS to CGO_CFLAGS to assure code hardening and optimization
- Related: #1821193

[1.0.0-67.rc91]
- update to https://github.com/opencontainers/runc/releases/tag/v1.0.0-rc91
- Related: #1821193

[1.0.0-66.rc10]
- synchronize containter-tools 8.3.0 with 8.2.1
- Related: #1821193

[1.0.0-65.rc10]
- address CVE-2019-19921 by updating to rc10
- Resolves: #1801887

[1.0.0-64.rc9]
- use no_openssl in BUILDTAGS (no vendored crypto in runc)
- Related: RHELPLAN-25139

[1.0.0-63.rc9]
- be sure to use golang >= 1.12.12-4
- Related: RHELPLAN-25139

[1.0.0-62.rc9]
- rebuild because of CVE-2019-9512 and CVE-2019-9514
- Resolves: #1766331, #1766303

[1.0.0-61.rc9]
- update to runc 1.0.0-rc9 release
- amend golang deps
- fixes CVE-2019-16884
- Resolves: #1759651

[1.0.0-60.rc8]
- Resolves: #1721247 - enable fips mode

[1.0.0-59.rc8]
- Resolves: #1720654 - rebase to v1.0.0-rc8

[1.0.0-57.rc5.dev.git2abd837]
- Resolves: #1693424 - podman rootless: cannot specify gid= mount options

[1.0.0-56.rc5.dev.git2abd837]
- change-default-root patch not needed as there's no docker on rhel8

[1.0.0-55.rc5.dev.git2abd837]
- Resolves: CVE-2019-5736

[1.0.0-54.rc5.dev.git2abd837]
- re-enable debuginfo

[1.0.0-53.rc5.dev.git2abd837]
- go toolset not in scl anymore

[1.0.0-52.rc5.dev.git2abd837]
- rebase

[2:1.0.0-51.dev.gitfdd8055]
- Fix handling of tmpcopyup

[2:1.0.0-49.rc5.dev.gitb4e2ecb]
- %gobuild uses no_openssl
- remove unused devel and unit-test subpackages

[2:1.0.0-48.rc5.dev.gitad0f525]
- build with %gobuild
- exlude i686 temporarily because of go-toolset issues

[1.0.0-47.dev.gitb4e2ecb]
- Rebuild with fixed binutils

[2:1.0.0-46.dev.gitb4e2ecb]
- Add patch https://github.com/opencontainers/runc/pull/1807 to allow
- runc and podman to work with sd_notify

[2:1.0.0-40.rc5.dev.gitad0f525]
- Remove sysclt handling, not needed in RHEL8
- Make sure package built with seccomp flags
- Remove rectty
- Add completions

[2:1.0.0-36.rc5.dev.gitad0f525]
- Better handling of user namespace

[2:1.0.0-31.rc5.git0cbfd83]
- Fix issues between SELinux and UserNamespace

[1.0.0-27.rc5.dev.git4bb1fe4]
- rebuilt, placed missing changelog entry back

[2:1.0.0-26.rc5.git4bb1fe4]
- release v1.0.0~rc5

[1.0.0-26.rc4.git9f9c962]
- Bump to the latest from upstream

[1.0.0-25.rc4.gite6516b3]
- built commit e6516b3

[1.0.0-24.rc4.dev.gitc6e4a1e.1]
- rebase to c6e4a1ebeb1a72b529c6f1b6ee2b1ae5b868b14f
- https://github.com/opencontainers/runc/pull/1651

[1.0.0-23.rc4.git1d3ab6d]
- Resolves: #1524654

[1.0.0-22.rc4.git1d3ab6d]
- Many Stability fixes
- Many fixes for rootless containers
- Many fixes for static builds

[1.0.0-21.rc4.dev.gitaea4f21]
- enable debuginfo and include -buildmode=pie for go build

[1.0.0-20.rc4.dev.gitaea4f21]
- use Makefile

[1.0.0-19.rc4.dev.gitaea4f21]
- disable debuginfo temporarily

[1.0.0-18.rc4.dev.gitaea4f21]
- enable debuginfo

[1.0.0-17.rc4.gitaea4f21]
- Add container-selinux prerequires to make sure runc is labeled correctly

[1.0.0-16.rc4.dev.gitaea4f21]
- correct the release tag 'rc4dev' -> 'rc4.dev' cause I'm OCD

[1.0.0-15.rc4dev.gitaea4f21]
- Use the same checkout as Fedora for lates CRI-O

[1.0.0-14.rc4dev.git84a082b]
- rebase to 84a082bfef6f932de921437815355186db37aeb1

[1.0.0-13.rc3.gitd40db12]
- Resolves: #1479489
- built commit d40db12

[1.0.0-12.1.gitf8ce01d]
- disable s390x temporarily because of indefinite wait times on brew

[1.0.0-11.1.gitf8ce01d]
- correct previous bogus date :
[1.0.0-10.1.gitf8ce01d]
- Resolves: #1441737 - run sysctl_apply for sysctl knob

[1.0.0-9.1.gitf8ce01d]
- Resolves: #1447078 - change default root path
- add commit e800860 from runc @projectatomic/change-root-path

[1.0.0-8.1.gitf8ce01d]
- Resolves: #1441737 - enable kernel sysctl knob /proc/sys/fs/may_detach_mounts

[1.0.0-7.1.gitf8ce01d]
- Resolves: #1429675
- built @opencontainers/master commit f8ce01d

[1.0.0-4.1.gitee992e5]
- built @projectatomic/master commit ee992e5

[1.0.0-3.rc2]
- Resolves: #1426674
- built projectatomic/runc_rhel_7 commit 5d93f81

[1.0.0-2.rc2]
- Resolves: #1419702 - rebase to latest upstream master
- built commit b263a43

[1.0.0-1.rc2]
- Resolves: #1412239 - *CVE-2016-9962* - set init processes as non-dumpable,
runc patch from Michael Crosby

[0.1.1-6]
- Resolves: #1373980 - rebuild for 7.3.0

[0.1.1-5]
- build with golang >= 1.6.2

[0.1.1-4]
- release tags were inconsistent in the previous build

[0.1.1-1]
- Resolves: #1341267 - rebase runc to v0.1.1

[0.1.0-3]
- add selinux build tag
- add BR: libseccomp-devel

[0.1.0-2]
- Resolves: #1328970 - add seccomp buildtag

[0.1.0-1]
- Resolves: rhbz#1328616 - rebase to v0.1.0

[0.0.8-1.git4155b68]
- Resolves: rhbz#1277245 - bump to 0.0.8
- Resolves: rhbz#1302363 - criu is a runtime dep
- Resolves: rhbz#1302348 - libseccomp-golang is bundled in Godeps
- manpages included

[1:0.0.5-0.1.git97bc9a7]
- Update to 0.0.5, introduce Epoch for Fedora due to 0.2 version instead of 0.0.2

[0.2-0.2.git90e6d37]
- First package for Fedora
resolves: #1255179

skopeo
[1:1.1.1-3.0.1]
- Handling redirect from the docker registry [Orabug: 29874238] (Nikita Gerasimov)
- Add oracle registry into the conf file [Orabug: 29845934 31306708]

[1:1.1.1-3]
- propagate proper CFLAGS to CGO_CFLAGS to assure code hardening and optimization
- Related: #1821193

[1:1.1.1-2]
- drop applied patches
- Related: #1821193

[1:1.1.1-1]
- update to https://github.com/containers/skopeo/releases/tag/v1.1.1
- Related: #1821193

[1:1.1.0-3]
- fix broken gating tests: docker unexpectedly removed htpasswd from
their 'registry:2' image, so we now use htpasswd from httpd-tools on host.

[1:1.1.0-2]
- fix 'CVE-2020-14040 skopeo: golang.org/x/text: possibility to trigger an infinite loop in encoding/unicode could lead to crash [rhel-8]'
- Resolves: #1854719

[1:1.1.0-1]
- update to https://github.com/containers/skopeo/releases/tag/v1.1.0
- Related: #1821193

[1:1.0.0-2]
- exclude i686 arch
- Related: #1821193

[1:1.0.0-1]
- update to https://github.com/containers/skopeo/releases/tag/v1.0.0
- Related: #1821193

[1:0.2.0-6]
- synchronize containter-tools 8.3.0 with 8.2.1
- Related: #1821193

[1:0.1.41-1]
- update to 0.1.41
- Related: #1821193

[1:0.1.40-10]
- modify registries.conf default configuration to be more secure by default
- Resolves: #1810053

[1:0.1.40-9]
- Fix CVE-2020-1702.
- Resolves: #1801922

[1:0.1.40-8]
- change the search order of registries and remove quay.io (#1784267)

[1:0.1.40-7]
- compile in FIPS mode
- Related: RHELPLAN-25139

[1:0.1.40-6]
- be sure to use golang >= 1.12.12-4
- Related: RHELPLAN-25139

[1:0.1.40-5]
- fix file list
- Related: RHELPLAN-25139

[1:0.1.40-4]
- fix symlinks in /usr/share/rhel/secrets and make
subscription-manager soft dependency to make them work
- Related: RHELPLAN-25139

[1:0.1.40-3]
- rebuild because of CVE-2019-9512 and CVE-2019-9514
- Resolves: #1772132, #1772137

[1:0.1.40-2]
- comment out mountopt option in order to fix gating tests
see bug 1769769
- Related: RHELPLAN-25139

[1:0.1.40-1]
- update to 0.1.40
- Related: RHELPLAN-25139

[1:0.1.37-5]
- Fix CVE-2019-10214 (#1734651).

[1:0.1.37-4]
- fix permissions of rhel/secrets
Resolves: #1691543

[1:0.1.37-3]
- Resolves: #1719994 - add registry.access.redhat.com to registries.conf

[1:0.1.37-2]
- Resolves: #1721247 - enable fips mode

[1:0.1.37-1]
- Resolves: #1720654 - rebase to v0.1.37

[1:0.1.36-1.git6307635]
- built upstream tag v0.1.36, including system tests

[1:0.1.32-4.git1715c90]
- Fixes @openshift/machine-config-operator#669
- install /etc/containers/oci/hooks.d and /etc/containers/certs.d

[1:0.1.32-3.git1715c90]
- rebase

[1:0.1.32-2.git1715c90]
- re-enable debuginfo

[1:0.1.31-12.gitb0b750d]
- go tools not in scl anymore

[1:0.1.31-11.gitb0b750d]
- Resolves: #1615609
- built upstream tag v0.1.31

[1:0.1.31-10.git0144aa8]
- Resolves: #1616069 - correct order of registries

[1:0.1.31-9.git0144aa8]
- Resolves: #1615609 - rebuild with gobuild tag 'no_openssl'

[1:0.1.31-8.git0144aa8]
- Resolves: #1614934 - containers-common soft dep on slirp4netns and
fuse-overlayfs

[1:0.1.31-7.git0144aa8]
- build with %gobuild
- use scl-ized go-toolset as dep
- disable i686 builds temporarily because of go-toolset issues

[1:0.1.31-6.git0144aa8]
- add statx to seccomp.json to containers-config
- add seccomp.json to containers-config

[1:0.1.31-4.git0144aa8]
- Resolves: #1597629 - handle dependency issue for skopeo-containers
- rename skopeo-containers to containers-common as in Fedora

[1:0.1.31-3.git0144aa8]
- Resolves: #1583762 - btrfs dep removal needs exclude_graphdriver_btrfs
buildtag

[1:0.1.31-2.git0144aa8]
- correct bz in previous changelog

[1:0.1.31-1.git0144aa8]
- Resolves: #1580938 - resolve FTBFS
- Resolves: #1583762 - remove dependency on btrfs-progs-devel
- bump to v0.1.31 (from master)
- built commit ca3bff6
- use go-toolset deps for rhel8

[0.1.29-5.git7add6fc]
- Fix small typo in registries.conf

[0.1.29-4.git]
- Add policy.json.5

[0.1.29-3.git]
- Add registries.conf

[0.1.29-2.git]
- Add registries.conf man page

[0.1.29-1.git]
- bump to 0.1.29-1
- Updated containers/image
docker-archive generates docker legacy compatible images
Do not create subdirectories for layers with no configs
Ensure the layer IDs in legacy docker/tarfile metadata are unique
docker-archive: repeated layers are symlinked in the tar file
sysregistries: remove all trailing slashes
Improve docker/* error messages
Fix failure to make auth directory
Create a new slice in Schema1.UpdateLayerInfos
Drop unused storageImageDestination.{image,systemContext}
Load a *storage.Image only once in storageImageSource
Support gzip for docker-archive files
Remove .tar extension from blob and config file names
ostree, src: support copy of compressed layers
ostree: re-pull layer if it misses uncompressed_digest|uncompressed_size
image: fix docker schema v1 -> OCI conversion
Add /etc/containers/certs.d as default certs directory

[0.1.28-2.git0270e56]
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild

[0.1.28-1.git]
- Vendor in fixed libraries in containers/image and containers/storage

[0.1.27-1.git]
- Fix Conflicts to Obsoletes
- Add better docs to man pages.
- Use credentials from authfile for skopeo commands
- Support storage='' in /etc/containers/storage.conf
- Add global --override-arch and --override-os options

[0.1.25-2.git2e8377a7]
- Add manifest type conversion to skopeo copy
- User can select from 3 manifest types: oci, v2s1, or v2s2
- e.g skopeo copy --format v2s1 --compress-blobs docker-archive:alp.tar dir:my-directory

[0.1.25-2.git7fd6f66b]
- Force storage.conf to default to overlay

[0.1.25-1.git7fd6f66b]
- Fix CVE in tar-split
- copy: add shared blob directory support for OCI sources/destinations
- Aligning Docker version between containers/image and skopeo
- Update image-tools, and remove the duplicate Sirupsen/logrus vendor
- makefile: use -buildmode=pie

[0.1.24-8.git28d4e08a]
- Add /usr/share/containers/mounts.conf

[0.1.24-7.git28d4e08a]
- Bug fixes
- Update to release

[0.1.24-6.dev.git28d4e08]
- skopeo-containers conflicts with docker-rhsubscription <= 2:1.13.1-31

[0.1.24-5.dev.git28d4e08]
- Add rhel subscription secrets data to skopeo-containers

[0.1.24-4.dev.git28d4e08]
- Update container/storage.conf and containers-storage.conf man page
- Default override to true so it is consistent with RHEL.

[0.1.24-3.dev.git28d4e08]
- built commit 28d4e08

[0.1.24-2.dev.git875dd2e]
- built commit 875dd2e
- Resolves: gh#416

[0.1.24-1.dev.gita41cd0]
- bump to 0.1.24-dev
- correct a prior bogus date
- fix macro in comment warning

[0.1.23-6.dev.git1bbd87]
- Change name of storage.conf.5 man page to containers-storage.conf.5, since
it conflicts with inn package
- Also remove default to 'overalay' in the configuration, since we should
- allow containers storage to pick the best default for the platform.

[0.1.23-5.git1bbd87f]
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild

[0.1.23-4.git1bbd87f]
- Rebuild with binutils fix for ppc64le (#1475636)

[0.1.23-3.git1bbd87f]
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild

[0.1.23-2.dev.git1bbd87]
- Fix storage.conf man page to be storage.conf.5.gz so that it works.

[0.1.23-1.dev.git1bbd87]
- Support for OCI V1.0 Images
- Update to image-spec v1.0.0 and revendor
- Fixes for authentication

[0.1.22-2.dev.git5d24b67]
- Epoch: 1 for CentOS as CentOS Extras' build already has epoch set to 1

[0.1.22-1.dev.git5d24b67]
- Give more useful help when explaining usage
- Also specify container-storage as a valid transport
- Remove docker reference wherever possible
- vendor in ostree fixes

[0.1.21-1.dev.git0b73154]
- Add support for storage.conf and storage-config.5.md from github container storage package
- Bump to the latest version of skopeo
- vendor.conf: add ostree-go
- it is used by containers/image for pulling images to the OSTree storage.
- fail early when image os does not match host os
- Improve documentation on what to do with containers/image failures in test-skopeo
- We now have the docker-archive: transport
- Integration tests with built registries also exist
- Support /etc/docker/certs.d
- update image-spec to v1.0.0-rc6

[0.1.20-1.dev.git0224d8c]
- BZ #1380078 - New release

[0.1.19-2.dev.git0224d8c]
- No golang support for ppc64. Adding exclude arch. BZ #1445490

[0.1.19-1.dev.git0224d8c]
- bump to v0.1.19-dev
- built commit 0224d8c

[0.1.17-3.dev.git2b3af4a]
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild

[0.1.17-2.dev.git2b3af4a]
- Rebuild for gpgme 1.18

[0.1.17-1.dev.git2b3af4a]
- bump to 0.1.17-dev

[0.1.14-6.git550a480]
- Fix BZ#1391932

[0.1.14-5.git550a480]
- Conflicts with atomic in skopeo-containers

[0.1.14-4.git550a480]
- built skopeo-containers

[0.1.14-3.gitd830391]
- built mtrmac/integrate-all-the-things commit d830391

[0.1.14-2.git362bfc5]
- built commit 362bfc5

[0.1.14-1.gitffe92ed]
- build origin/master commit ffe92ed

[0.1.13-6]
- https://fedoraproject.org/wiki/Changes/golang1.7

[0.1.13-5]
- include go-srpm-macros and compiler(go-compiler) in fedora conditionals
- define %gobuild if not already
- add patch to build with older version of golang

[0.1.13-4]
- update to v0.1.12

[0.1.12-3]
- fix go build source path

[0.1.12-2]
- update to v0.1.12

[0.1.11-1]
- update to v0.1.11

[0.1.10-1]
- update to v0.1.10
- change runcom -> projectatomic

[0.1.9-1]
- update to v0.1.9

[0.1.8-1]
- update to v0.1.8

[0.1.4-2]
- https://fedoraproject.org/wiki/Changes/golang1.6

[0.1.4]
- First package for Fedora

slirp4netns
[1.1.4-2]
- use proper CFLAGS
- Related: #1821193

[1.1.4-1]
- update to https://github.com/rootless-containers/slirp4netns/releases/tag/v1.1.4
- Related: #1821193

[1.1.3-1]
- update to https://github.com/rootless-containers/slirp4netns/releases/tag/v1.1.3
- Related: #1821193

[1.1.2-1]
- update to https://github.com/rootless-containers/slirp4netns/releases/tag/v1.1.2
- Related: #1821193

[1.1.1-1]
- update to https://github.com/rootless-containers/slirp4netns/releases/tag/v1.1.1
- Related: #1821193

[1.1.0-1]
- update to https://github.com/rootless-containers/slirp4netns/releases/tag/v1.1.0
- Related: #1821193

[1.0.1-1]
- update to https://github.com/rootless-containers/slirp4netns/archive/v1.0.1.tar.gz
- Related: #1821193

udica
[0.2.2-1]
- https://github.com/containers/udica/releases/tag/v0.2.2
- Related: #1821193




Updated Packages


Release/ArchitectureFilenameMD5sumSuperseded By Advisory
Oracle Linux 8 (aarch64) buildah-1.15.1-2.0.1.module+el8.3.0+7866+f387f528.src.rpmf4b3c9e06142593fb16dcad665673dc8-
cockpit-podman-18.1-2.module+el8.3.0+7866+f387f528.src.rpmbae39050b0a63d305e8b0cead647521a-
conmon-2.0.20-2.module+el8.3.0+7866+f387f528.src.rpm16367197229e11b4f966355a0f38e3db-
container-selinux-2.144.0-1.module+el8.3.0+7866+f387f528.src.rpmfb352d1a580b142fc7437aa5453eafca-
containernetworking-plugins-0.8.6-2.module+el8.3.0+7866+f387f528.src.rpmc1130c828614c55239acf00c4770e4a0-
criu-3.14-2.module+el8.3.0+7866+f387f528.src.rpmbb85bd07079d5a4c9b9dc696f4ad6914-
crun-0.14.1-2.module+el8.3.0+7866+f387f528.src.rpm397018040390d7d4e1171d84806ed0eb-
fuse-overlayfs-1.1.2-3.module+el8.3.0+7866+f387f528.src.rpma660345fb77c66cc3ffd88e6e2efede0-
libslirp-4.3.1-1.module+el8.3.0+7866+f387f528.src.rpmc8ad24b76fdd001285d777bee07d7d9e-
oci-seccomp-bpf-hook-1.1.2-3.module+el8.3.0+7866+f387f528.src.rpm842a9a76d78a408a5fba426a97baaa8c-
python-podman-api-1.2.0-0.2.gitd0a45fe.module+el8.3.0+7866+f387f528.src.rpm897659cadfba9dd9fc83a62399f280b6-
runc-1.0.0-68.rc92.module+el8.3.0+7866+f387f528.src.rpmcba994d336e811917c6ee64dfc71d451-
skopeo-1.1.1-3.0.1.module+el8.3.0+7866+f387f528.src.rpma448b0ece3a1db744e0bb87ad25d89d7-
slirp4netns-1.1.4-2.module+el8.3.0+7866+f387f528.src.rpm7cb9e48395e1d5acb6da9350363f4bb9-
udica-0.2.2-1.module+el8.3.0+7866+f387f528.src.rpm15f1ad2348207f3d8d94f574fbffb23f-
buildah-1.15.1-2.0.1.module+el8.3.0+7866+f387f528.aarch64.rpmce7409ae0aed1c7487c85f858f4acc07-
buildah-tests-1.15.1-2.0.1.module+el8.3.0+7866+f387f528.aarch64.rpmbcc25536bef5aa757608daa44fe4f3de-
cockpit-podman-18.1-2.module+el8.3.0+7866+f387f528.noarch.rpm4696949eb53a1dec1be6e8a5cda7578f-
conmon-2.0.20-2.module+el8.3.0+7866+f387f528.aarch64.rpmf926c26f361b85b944c250980965ceec-
container-selinux-2.144.0-1.module+el8.3.0+7866+f387f528.noarch.rpmb69d2be8af57e2023a629fb35a7f4c46-
containernetworking-plugins-0.8.6-2.module+el8.3.0+7866+f387f528.aarch64.rpmd36eb2cf481cd2eab2290704f49e60b5-
containers-common-1.1.1-3.0.1.module+el8.3.0+7866+f387f528.aarch64.rpm9cd5d88890bbea6af1d08b6cabbfb47a-
crit-3.14-2.module+el8.3.0+7866+f387f528.aarch64.rpmaa87658610c617e499b858e7f2a64399-
criu-3.14-2.module+el8.3.0+7866+f387f528.aarch64.rpm6972add78eb1667c5c5cd8b19ffd939a-
crun-0.14.1-2.module+el8.3.0+7866+f387f528.aarch64.rpm1731b985eb4a0429a685f32d9372b35e-
fuse-overlayfs-1.1.2-3.module+el8.3.0+7866+f387f528.aarch64.rpmf6ae6670d3f4f32b616ccb36fdecd624-
libslirp-4.3.1-1.module+el8.3.0+7866+f387f528.aarch64.rpm6756842122dc27e7fd6e840f5b75abed-
libslirp-devel-4.3.1-1.module+el8.3.0+7866+f387f528.aarch64.rpma968c4af51b4b3e55b473f0aecabd230-
oci-seccomp-bpf-hook-1.1.2-3.module+el8.3.0+7866+f387f528.aarch64.rpmfabf5a67e84caca67fb16ef4957b3d9a-
podman-2.0.5-5.0.1.module+el8.3.0+7866+f387f528.aarch64.rpma06bc6bed94171de9a36766b8321c19b-
podman-catatonit-2.0.5-5.0.1.module+el8.3.0+7866+f387f528.aarch64.rpm1a1a3e746c0cea2a2ab38a9de13b1a49-
podman-docker-2.0.5-5.0.1.module+el8.3.0+7866+f387f528.noarch.rpm517cdbcf74a64111674634e524360f25-
podman-remote-2.0.5-5.0.1.module+el8.3.0+7866+f387f528.aarch64.rpmf0d53aaa36129d32e34093b7f417b10e-
podman-tests-2.0.5-5.0.1.module+el8.3.0+7866+f387f528.aarch64.rpm34c33d209ce6b5f3873b6df7ad17659e-
python-podman-api-1.2.0-0.2.gitd0a45fe.module+el8.3.0+7866+f387f528.noarch.rpm812f6036088c3dac7a9dcdecd921da5c-
python3-criu-3.14-2.module+el8.3.0+7866+f387f528.aarch64.rpm4de7aa6909a079b271402027a910b6f6-
runc-1.0.0-68.rc92.module+el8.3.0+7866+f387f528.aarch64.rpm7f466365fb00d340f51ed46c2206bdc9-
skopeo-1.1.1-3.0.1.module+el8.3.0+7866+f387f528.aarch64.rpm1d1092b3ccdc97064feb5058b0256094-
skopeo-tests-1.1.1-3.0.1.module+el8.3.0+7866+f387f528.aarch64.rpm670512d31a6c9eb3c0d7b7e70d9bb4fe-
slirp4netns-1.1.4-2.module+el8.3.0+7866+f387f528.aarch64.rpmf6c2e9e10004b48b761a1866ded996cf-
udica-0.2.2-1.module+el8.3.0+7866+f387f528.noarch.rpm946a767151cb82f241a7bb21b9486949-
Oracle Linux 8 (x86_64) buildah-1.15.1-2.0.1.module+el8.3.0+7866+f387f528.src.rpmf4b3c9e06142593fb16dcad665673dc8-
cockpit-podman-18.1-2.module+el8.3.0+7866+f387f528.src.rpmbae39050b0a63d305e8b0cead647521a-
conmon-2.0.20-2.module+el8.3.0+7866+f387f528.src.rpm16367197229e11b4f966355a0f38e3db-
container-selinux-2.144.0-1.module+el8.3.0+7866+f387f528.src.rpmfb352d1a580b142fc7437aa5453eafca-
containernetworking-plugins-0.8.6-2.module+el8.3.0+7866+f387f528.src.rpmc1130c828614c55239acf00c4770e4a0-
criu-3.14-2.module+el8.3.0+7866+f387f528.src.rpmbb85bd07079d5a4c9b9dc696f4ad6914-
crun-0.14.1-2.module+el8.3.0+7866+f387f528.src.rpm397018040390d7d4e1171d84806ed0eb-
fuse-overlayfs-1.1.2-3.module+el8.3.0+7866+f387f528.src.rpma660345fb77c66cc3ffd88e6e2efede0-
libslirp-4.3.1-1.module+el8.3.0+7866+f387f528.src.rpmc8ad24b76fdd001285d777bee07d7d9e-
oci-seccomp-bpf-hook-1.1.2-3.module+el8.3.0+7866+f387f528.src.rpm842a9a76d78a408a5fba426a97baaa8c-
python-podman-api-1.2.0-0.2.gitd0a45fe.module+el8.3.0+7866+f387f528.src.rpm897659cadfba9dd9fc83a62399f280b6-
runc-1.0.0-68.rc92.module+el8.3.0+7866+f387f528.src.rpmcba994d336e811917c6ee64dfc71d451-
skopeo-1.1.1-3.0.1.module+el8.3.0+7866+f387f528.src.rpma448b0ece3a1db744e0bb87ad25d89d7-
slirp4netns-1.1.4-2.module+el8.3.0+7866+f387f528.src.rpm7cb9e48395e1d5acb6da9350363f4bb9-
udica-0.2.2-1.module+el8.3.0+7866+f387f528.src.rpm15f1ad2348207f3d8d94f574fbffb23f-
buildah-1.15.1-2.0.1.module+el8.3.0+7866+f387f528.x86_64.rpm17c00ab26f13d5f64b1fa7f1ae36c0a1-
buildah-tests-1.15.1-2.0.1.module+el8.3.0+7866+f387f528.x86_64.rpm7f1bf09c9a2fae3fbd9c04e1be314dae-
cockpit-podman-18.1-2.module+el8.3.0+7866+f387f528.noarch.rpm4696949eb53a1dec1be6e8a5cda7578f-
conmon-2.0.20-2.module+el8.3.0+7866+f387f528.x86_64.rpm632643465e5dde5c885f6f4f9b9c4176-
container-selinux-2.144.0-1.module+el8.3.0+7866+f387f528.noarch.rpmb69d2be8af57e2023a629fb35a7f4c46-
containernetworking-plugins-0.8.6-2.module+el8.3.0+7866+f387f528.x86_64.rpm663daa2c02651945fca3ed2dab6d4331-
containers-common-1.1.1-3.0.1.module+el8.3.0+7866+f387f528.x86_64.rpm096ce6d4e3a7a7391d1905dbbb0ec7c5-
crit-3.14-2.module+el8.3.0+7866+f387f528.x86_64.rpm9f2b4ab0a2e59d8142da18cedbc95351-
criu-3.14-2.module+el8.3.0+7866+f387f528.x86_64.rpmb5e0556f98a6e9494342f1d4fe59182d-
crun-0.14.1-2.module+el8.3.0+7866+f387f528.x86_64.rpm2f057cb10bc99a416fc78b41cf30a8ad-
fuse-overlayfs-1.1.2-3.module+el8.3.0+7866+f387f528.x86_64.rpmb88ff71ca85e9b763af28bfdcdcb04ca-
libslirp-4.3.1-1.module+el8.3.0+7866+f387f528.x86_64.rpm46489be5ad0aaeee392493c67d0a9afa-
libslirp-devel-4.3.1-1.module+el8.3.0+7866+f387f528.x86_64.rpm938feaa819edec5cb895530f8b402636-
oci-seccomp-bpf-hook-1.1.2-3.module+el8.3.0+7866+f387f528.x86_64.rpma72574e319ac5ae6b6281eaa40b8a14b-
podman-2.0.5-5.0.1.module+el8.3.0+7866+f387f528.x86_64.rpm1ab84f671534d01ebc68e74f83a8de41-
podman-catatonit-2.0.5-5.0.1.module+el8.3.0+7866+f387f528.x86_64.rpmc86d65f12b5da1eec65e3cc7935cc63c-
podman-docker-2.0.5-5.0.1.module+el8.3.0+7866+f387f528.noarch.rpm517cdbcf74a64111674634e524360f25-
podman-remote-2.0.5-5.0.1.module+el8.3.0+7866+f387f528.x86_64.rpmf95fd1dc43cce38dd068a44664e994ec-
podman-tests-2.0.5-5.0.1.module+el8.3.0+7866+f387f528.x86_64.rpm3c213014c9d3a21c3c73b2bcd2adb356-
python-podman-api-1.2.0-0.2.gitd0a45fe.module+el8.3.0+7866+f387f528.noarch.rpm812f6036088c3dac7a9dcdecd921da5c-
python3-criu-3.14-2.module+el8.3.0+7866+f387f528.x86_64.rpm98597bd9db03009b8849b21a43ac7694-
runc-1.0.0-68.rc92.module+el8.3.0+7866+f387f528.x86_64.rpm12bf822c0fdc815626709176aa01c6f0-
skopeo-1.1.1-3.0.1.module+el8.3.0+7866+f387f528.x86_64.rpmced3ec2cba6edf9db4d1535a19999e37-
skopeo-tests-1.1.1-3.0.1.module+el8.3.0+7866+f387f528.x86_64.rpm7e5ac5186d0fe62522b75a8389242de7-
slirp4netns-1.1.4-2.module+el8.3.0+7866+f387f528.x86_64.rpm03c715a8342bfc1709cf0c0427b3d351-
udica-0.2.2-1.module+el8.3.0+7866+f387f528.noarch.rpm946a767151cb82f241a7bb21b9486949-



This page is generated automatically and has not been checked for errors or omissions. For clarification or corrections please contact the Oracle Linux ULN team

software.hardware.complete