ELSA-2014-1636

ELSA-2014-1636 - java-1.8.0-openjdk security update

Type:SECURITY
Severity:IMPORTANT
Release Date:2014-10-22

Description


[1:1.8.0.25-1.b17]
- Update to October CPU patch update.
- Resolves: RHBZ#1148896

[1:1.8.0.20-3.b26]
- fixed headless (policytool moved to normal)
- jre/bin/policytool added to not headless exclude list
- updated aarch694 source
- ppc64le synced from fedora
- Resolves: rhbz#1081073

[1:1.8.0.20-2.b26]
- forcing build by itself (jdk8 by jdk8)
- Resolves: rhbz#1081073

[1:1.8.0.20-1.b26]
- updated to u20-b26
- adapted patch9999 enableArm64.patch
- adapted patch100 s390-java-opts.patch
- adapted patch102 size_t.patch
- removed upstreamed patch 0001-PPC64LE-arch-support-in-openjdk-1.8.patch
- adapted system-lcms.patch
- removed patch8 set-active-window.patch
- removed patch9 javadoc-error-jdk-8029145.patch
- removed patch10 javadoc-error-jdk-8037484.patch
- removed patch99 applet-hole.patch - itw 1.5.1 is able to ive without it
- Resolves: rhbz#1081073

[1:1.8.0.11-19.b12]
- fixed desktop icons
- Icon set to java-1.8.0
- Development removed from policy tool
- Resolves: rhbz#1081073

[1:1.8.0.11-18.b12]
- fixed jstack
- Resolves: rhbz#1081073

[1:1.8.0.11-15.b12]
- fixed provides/obsolates
- Resolves: rhbz#1081073

[1:1.8.0.11-14.b12]
- mayor rework of specfile - sync with f21
- accessibility kept removed
- lua script kept unsync
- priority and epoch kept on 0 - not included disable-doclint patch
- kept bundled lcms
- unused OrderWithRequires
- used with-stdcpplib instead of with-stdc++lib
- Resolves: rhbz#1081073

[1:1.8.0.11-4.b13]
- Added security patches
- Resolves: rhbz#1081073

[1:1.8.0.5-6.b13]
- Removed accessibility package
- removed patch3 java-atk-wrapper-security.patch
- removed its files and declaration
- removed creation of libatk-wrapper.so and java-atk-wrapper.jar symlinks
- removed generation of accessibility.properties
- Resolves: rhbz#1113078

[1:1.8.0.5-5.b13]
- priority lowered to 00000
- Resolves: rhbz#1081073

[1:1.8.0.5-4.b13]
- Initial import from fedora
- Used bundled lcms2
- added java-1.8.0-openjdk-disable-system-lcms.patch
- --with-lcms changed to bundled
- removed build requirement
- excluded removal of lcms from remove-intree-libraries.sh
- removed --with-extra-cflags="-fno-devirtualize" and --with-extra-cxxflags="-fn
o-devirtualize"---
- added patch998, rhel6-built.patch to
- fool autotools
- replace all ++ chars in autoconfig files by pp
- --with-stdc++lib=dynamic replaced by --with-stdcpplib=dynamic
- Bumped release
- Set epoch to 0
- removed patch6, disable-doclint-by-default.patch
- Resolves: rhbz#1081073


Related CVEs


CVE-2014-6457
CVE-2014-6502
CVE-2014-6504
CVE-2014-6506
CVE-2014-6511
CVE-2014-6512
CVE-2014-6517
CVE-2014-6519
CVE-2014-6531
CVE-2014-6558
CVE-2014-6468
CVE-2014-6562

Updated Packages


Release/ArchitectureFilenameMD5sumSuperseded By Advisory
Oracle Linux 6 (i386) java-1.8.0-openjdk-1.8.0.25-1.b17.el6.src.rpm7a35c9c9812c6eb6399d788107138bb2ELSA-2017-1789
java-1.8.0-openjdk-1.8.0.25-1.b17.el6.i686.rpma5fe3fe10095af40d248c17cdada08e6ELSA-2017-1789
java-1.8.0-openjdk-demo-1.8.0.25-1.b17.el6.i686.rpmdfbe6644798c6e0c6506a09539bcbf47ELSA-2017-1789
java-1.8.0-openjdk-devel-1.8.0.25-1.b17.el6.i686.rpm198fc0574e54240e19fb64d6a49ff777ELSA-2017-1789
java-1.8.0-openjdk-headless-1.8.0.25-1.b17.el6.i686.rpm03838df98581ad38a008692770ff492eELSA-2017-1789
java-1.8.0-openjdk-javadoc-1.8.0.25-1.b17.el6.noarch.rpme91545dd4f35350e10cc3419e8f158a5ELSA-2017-1789
java-1.8.0-openjdk-src-1.8.0.25-1.b17.el6.i686.rpm505634ee3674f68c46e8c72c7ce83bbdELSA-2017-1789
Oracle Linux 6 (x86_64) java-1.8.0-openjdk-1.8.0.25-1.b17.el6.src.rpm7a35c9c9812c6eb6399d788107138bb2ELSA-2017-1789
java-1.8.0-openjdk-1.8.0.25-1.b17.el6.x86_64.rpmdf4548e5eee8cd0ff403ff2ef6b391c0ELSA-2017-1789
java-1.8.0-openjdk-demo-1.8.0.25-1.b17.el6.x86_64.rpm4ce040d50eb691915d8e62c34ad4ec26ELSA-2017-1789
java-1.8.0-openjdk-devel-1.8.0.25-1.b17.el6.x86_64.rpm9d5d06cbf55ab0026540c925d9238027ELSA-2017-1789
java-1.8.0-openjdk-headless-1.8.0.25-1.b17.el6.x86_64.rpm1d6db221f5c92e35d0fbb0d272f81766ELSA-2017-1789
java-1.8.0-openjdk-javadoc-1.8.0.25-1.b17.el6.noarch.rpme91545dd4f35350e10cc3419e8f158a5ELSA-2017-1789
java-1.8.0-openjdk-src-1.8.0.25-1.b17.el6.x86_64.rpm1df799b774fd40bb15801b1fbe362120ELSA-2017-1789



This page is generated automatically and has not been checked for errors or omissions. For clarification or corrections please contact the Oracle Linux ULN team

software.hardware.complete