ELSA-2019-2229

ELSA-2019-2229 - spice-gtk security and bug fix update

Type:SECURITY
Severity:MODERATE
Release Date:2019-08-13

Description


libgovirt
[0.3.4-2]
- Parse XML nodes automatically
Related: rhbz#1427467
- Set detailed error message for async call
Related: rhbz#1427467

spice-gtk
[0.35-4]
- Fix bad channel-reset on usbredir
Resolves: rhbz#1625550

[0.35-3]
- Fix insufficient encoding checks for LZ
Resolves: rhbz#1598652

spice-vdagent
[0.14.0-18]
- Fix clipboard logs on requests for targets on grab from client
Resolves: rhbz#1594876
- Make some clipboard logs debug instead of error
Resolves: rhbz#1686008

[0.14.0-17]
- Fix 'Dependency failed for Activation socket' message
Resolves: rhbz#1545212
- Fix socket leak
Resolves: rhbz#1650596

virt-viewer
[5.0.15]
- Fix check for ovirt functions
Related: rhbz#1427467

[5.0-14]
- Listen to SpiceSession::disconnected
Resolves: rhbz#1505809

[5.0.13]
- Bypass errors from oVirt foreign menu queries
Related: rhbz#1428401

[5.0-12]
- Centralize recent dialog
Resolves: rhbz#1508274
- Always add guest name as comment
Resolves: rhbz#1623756
- Mark PrintScreen as translatable
Resolves: rhbz#1510411
- Remove symlink to spice-xpi-client-remote-viewer on update (it was dropped)
Resolves: rhbz#1658325


Related CVEs


CVE-2018-10893

Updated Packages


Release/ArchitectureFilenameMD5sumSuperseded By Advisory
Oracle Linux 7 (aarch64) libgovirt-0.3.4-3.el7.src.rpmd17238a621c5e43ab28df46799f2e678-
spice-gtk-0.35-4.el7.src.rpm939a8d4daec1b747decab6ad8e6c49f4-
spice-vdagent-0.14.0-18.el7.src.rpm10a63c25f3265bb2f7e8df78b3df8d48-
virt-viewer-5.0-15.el7.src.rpm1e82aceb3f0f678b25d813d9db12e971-
libgovirt-0.3.4-3.el7.aarch64.rpm854fded4530e51fdd6ca2b111fd64650-
libgovirt-devel-0.3.4-3.el7.aarch64.rpm06024e2e962621cdcda9f40a73a98207-
spice-glib-0.35-4.el7.aarch64.rpmf01e8b464e01ec603756bcb967e4190d-
spice-glib-devel-0.35-4.el7.aarch64.rpmcb0bc9ec7f22d38e5cb040fc5d590e20-
spice-gtk-tools-0.35-4.el7.aarch64.rpm7f90e4fc58799b82b712ebabdd91593b-
spice-gtk3-0.35-4.el7.aarch64.rpm138dc406046e2c69048eccedfbbe79bd-
spice-gtk3-devel-0.35-4.el7.aarch64.rpm0b06d7ffc702840db87c1732123996da-
spice-gtk3-vala-0.35-4.el7.aarch64.rpma89197c05256beb21b676ec72c710e18-
spice-vdagent-0.14.0-18.el7.aarch64.rpma5aa6abd1ceb891d04185fa31f50fb3d-
virt-viewer-5.0-15.el7.aarch64.rpmb407cf45595bc938a4d0f7cae5c9beab-
Oracle Linux 7 (x86_64) libgovirt-0.3.4-3.el7.src.rpmd17238a621c5e43ab28df46799f2e678-
spice-gtk-0.35-4.el7.src.rpm939a8d4daec1b747decab6ad8e6c49f4-
spice-vdagent-0.14.0-18.el7.src.rpm10a63c25f3265bb2f7e8df78b3df8d48-
virt-viewer-5.0-15.el7.src.rpm1e82aceb3f0f678b25d813d9db12e971-
libgovirt-0.3.4-3.el7.i686.rpmfca399f3c83cdd3e11490e5721e2a07b-
libgovirt-0.3.4-3.el7.x86_64.rpmc025d6641cbf483916dcd50cec337c97-
libgovirt-devel-0.3.4-3.el7.i686.rpm901cb6c1956830db1ed6558df966b337-
libgovirt-devel-0.3.4-3.el7.x86_64.rpm2b98c6ec63ae1e384da7c8d0b0a8b8b5-
spice-glib-0.35-4.el7.i686.rpmd5f77fe69743b2708126c5949dc3599f-
spice-glib-0.35-4.el7.x86_64.rpm3dc7e699b93dbc8b117a962d79fd0402-
spice-glib-devel-0.35-4.el7.i686.rpmbaf76fbf072fb1c98ae28361a97fd904-
spice-glib-devel-0.35-4.el7.x86_64.rpm0e0741192391a0ef4ece8cd41c04c215-
spice-gtk-tools-0.35-4.el7.x86_64.rpmb5508dab535edf72dbbcaf6a836c67ee-
spice-gtk3-0.35-4.el7.i686.rpm852c3e1e8050dc26cf1d6e56c7c0ceb0-
spice-gtk3-0.35-4.el7.x86_64.rpma037f491331702c81f06489f5c5d7d1e-
spice-gtk3-devel-0.35-4.el7.i686.rpm7c2c12ef30897eb35e4f0df573463df0-
spice-gtk3-devel-0.35-4.el7.x86_64.rpme2f66638f26aab34c8d742b872831e8a-
spice-gtk3-vala-0.35-4.el7.x86_64.rpm576199f301748d130da292a1b9502de5-
spice-vdagent-0.14.0-18.el7.x86_64.rpmb528469810a3abdb67604c9997edb166-
virt-viewer-5.0-15.el7.x86_64.rpm5528651aae0eb12a8721411c8ec3591a-



This page is generated automatically and has not been checked for errors or omissions. For clarification or corrections please contact the Oracle Linux ULN team

software.hardware.complete